HowTo

GitLab: обновление бандлов ruby

gitlab bundle updateПосле очередного «незапланированного» обновления у меня вдруг отвалился gitlab.
В логах

/home/git/gitlab/vendor/bundle/ruby/2.1.0/gems/activesupport-4.1.9/lib/active_su
pport/dependencies.rb:247:in `require': Incorrect MySQL client library version! 
This gem was compiled for 5.5.42 but the client library is 5.6.25. (RuntimeError
)

Надо обновлять.
Беда в том, что в ruby я не нашел аналога pip update или что-то в таком духе.

Для обновления предустановленных бандлов нужно удалить старые и поставить новые (заново).

$ sudo -u git mv /home/git/gitlab/vendor/bundle{,.bkp}
sudo -u git -H bundle install --without development test postgres --deployment

Мануал по обновлению гитлаба: https://gitlab.com/gitlab-org/gitlab-ce/blob/master/doc/update/patch_versions.md.

Добавить комментарий

Заполните поля или щелкните по значку, чтобы оставить свой комментарий:

Логотип WordPress.com

Для комментария используется ваша учётная запись WordPress.com. Выход / Изменить )

Фотография Twitter

Для комментария используется ваша учётная запись Twitter. Выход / Изменить )

Фотография Facebook

Для комментария используется ваша учётная запись Facebook. Выход / Изменить )

Google+ photo

Для комментария используется ваша учётная запись Google+. Выход / Изменить )

Connecting to %s